[OpenTRV-interest] Tinkering kit / Conrad radiator valve and security code

Mon May 19 12:05:45 BST 2014

I think that Gmail has messed up some of my quoting. I've tried to add a
couple of points inline, but Gmail is making them appear to be Damon's text

On 19 May 2014 10:44, Damon Hart-Davis <EMAIL ADDRESS HIDDEN> wrote:

> Hi,
> On 19 May 2014, at 10:24, Alasdair Macdonald <EMAIL ADDRESS HIDDEN>
> wrote:
> > Last night I tried to fit my Conrad TRV to a radiator, in order that I
> could try to establish a dialogue between the TRV and my OpenTRV tinkering
> kit.
> >
> > Fitting the TRV proved to be a very frustrating experience, primarily
> because the Conrad instructions assume that you have additional kit, and
> that some relevant instructions will be available in the instructions for
> that kit.
> >
> > Conrad instructions for "Valve Drive 57 00 56":
> >
> > "In the case of valves made by Danfoss, you first have to put on one of
> the supplied adaptors (see the operating manual for the complete system)”.
> Sorry that this has been so frustrating: I haven’t managed to fit one of
> these units to anything other than a vanilla “Danfoss” M30x1.5 fitting, so
> you may be our new “expert”…  %-|P
Well, I'm still not at all convinced that the TRV is properly connected to
the radiator pin, in such as way as to be able to actuate it. The distance
between radiator pin (with extender) and the pin in the TRV is a concern,
but the shapes of both are also a concern; I don't know if it will work. I
do know of a helpful plumber that I may need to call in, but even if the
mechanical connection is bad, that doesn't mean that testing can't
continue. If I can read the LCD display of the TRV, when it says something
other than 0%, that will be a meaningful result.

> I’ll comment on some of the OpenTRV unit serial output below, since that’s
> all my fault...

>  >
> > I followed the instructions in the Valve manual for setting up the
> valve. Refer back to
> 550000-574999/570056-an-03-ml-Ventilantrieb_de_en_fr_nl.pdf . As the valve
> is powered, I see the readouts described in the manual. First C1, then
> "93", then C2, then "74", then A1. I understand that 93 / 74 is the house
> code pre-programmed into this valve.
> >
> > Manual states to press the button for 3+ seconds to put the valve into a
> state where it may expect to receive a "security code". The valve has been
> awaiting this security code since ~1am last night.
> You should hear another ‘beep’.

I heard the second beep now, following your advice below.

> >
> > I logged in to the openTRV controller (it has either lost ~10 minutes in
> the past 7 weeks, or I must have switched it off / on at an appropriate
> time -10 minutes past midnight?). I previously reported that my controller
> did NOT reboot when I fired up the Arduino IDE. Certainly today (a few
> minutes ago), it DID reboot; the first things that I saw in my terminal
> screen were the reboot messages.
> Internally the OpenTRV unit does not keep time through a power-up or reset
> and simply stores it inside in 15-minute increments, so may at worst case
> jump forward or back that amount, though the typical error is much smaller.
> >
> > Last night I tried to execute the House Code command to the controller.
> It looks as though it has succeeded somewhat; every line of output now
> terminates with "HC93 74 s".
> >
> > I also got some new "FHT8V" messages, and I don't know what to make of
> these.
> >
> >
> >
> > Here's some output from last night. I've removed some greater than signs
> from the output, in case your mail reader might misinterpret or hide the
> lines in question.
> >
> >
> > "Normal" output, before I started tinkering:
> >
> > =F0%@22C7;T0 50 W255 0 F255 0 W255 0 F255 0;S10 10 21 cffO
> Frost mode, valve open 0%, temperature 22+7/16C; nominal time 00:50, no
> LEARNed programmes set; Setpoint currently 10C (10C frost, 21C warm), in
> ‘c'omfort mode, this and next hours predicted to be frost mode, highly
> probable ‘O’ccupancy.
> >
> >
> > So I tried to send the "Set Wireless House Codes" command, per the help
> text, and using the codes displayed by my Conrad valve:
> >
> > H 93 74
> > =F0%@22C7;T0 50 W255 0 F255 0 W255 0 F255 0;S10 10 21 cffO;HC93 74 s
> > 50:52:0 FHT8V SYNC...
> >
> > So the output has ";HC93 74 s" appended, and some new output has begun
> to appear.
> Yes, you set the house code and the trailing ’s’ in the section showing
> that indicates ’s’ynicing with the valve which takes a couple of minutes.
> >
> > <snip>
> >
> > More "normal" output, with the HC stuff at the end:
> >
> > =F0%@22C8;T0 51 W255 0 F255 0 W255 0 F255 0;S10 10 21 cffO;HC93 74 s
> >
> >
> >
> > And some exciting new output, which I don't know how to interpret (this
> was around 1am; the OpenTRV board seems to be saying that it is 0:55am in
> the output below):
> >
> >
> > 52:56:73 FHT8V SYNC FINAL
> The OpenTRV unit should now be in sync with the valve and the valve should
> have gone ‘beep’/
> > 54:52:73 FHT8V TX
> A transmission was made to the valve (happens about every 2 minutes).
> > =F0%@22CA;T0 55 W255 0 F255 0 W255 0 F255 0;S10 10 21 cffO;HC93 74
> The sync is over (no trailing ’s’ in the final section).
> >
> >
> > 56:48:73 FHT8V TX
> > 58:44:73 FHT8V TX
> A couple more transmissions (with timestamps, basically
> minutes:seconds:s/128).
> > =F0%@22CA;T0 58 W255 0 F255 0 W255 0 F255 0;S10 10 21 cffO;HC93 74
> >
> >
> >
> >
> > Here I input the correct time at 1:04am:
> > T 01 04
> > =F0%@22CA;T1 4 W255 0 F255 0 W255 0 F255 0;S10 10 21 cffO;HC93 74
> >
> >
> > 66:40:73 FHT8V TX
> >
> >
> >
> > This morning I am getting stuff like:
> >
> > 610:26:74 FHT8V SYNC FINAL
> > 612:22:73 FHT8V TX
> > =F0%@23CD;T10 12 W255 0 F255 0 W255 0 F255 0;S10 10 21 cffO;HC93 74
> It should not SYNC again unless there is a problem or you power-cycle or
> reset it: if you’ve got a complete transcript of the output I’d like to see
> it.  Possibly the OpenTRV unit reset due to a bug.  There have been a
> number of updates to try to address this.
> >
> > 614:18:73 FHT8V TX
> >
> > However, my Conrad TRV still seems to be awaiting receipt of a "security
> code". I would like to send this from the OpenTRV controller, but I can't
> figure out from the help text what I should send (and is timing
> important??). The valve STILL shows "AC" with a flashing antenna; so
> according to the manual it's awaiting said code.
> I think you’ve got the valve into a state that I’ve never seen, possibly a
> pairing state.  I haven’t written code to use any such feature yet.
> Can you please go through out set-up guide starting with the batteries out
> of both the valve and OpenTRV units?
> http://opentrv.org.uk/documents/
> Damon -

Your suggestion worked. After a bit of confusion ;-)

I don't have a complete transcript of last night's output, but I believe
that I did copy all the significant parts (ie I only excised a few standard
"=F0%@25C1;T ..." type lines).

You suggested that I look at the "set up guide". I found this as a section
within the "User Guide"; whereas I started looking for a separate "set up"

(Also, I opened the Rev2 "Quick Start Guide". It refers to a "user manual"
at http://goo.gl/j1f7nP ; however this link takes us to
http://opentrv.org.uk/files/user-guide-rev2-pms.pdf and doesn't work -
looks like the "-pms suffix is wrong.)

Then, I looked in http://opentrv.org.uk/files/user-guide-rev2.pdf

And found:

Your installer should have done this for you already including setting the
house codes but just in case, here it is. Please note that it is different
whether you run your OpenTRV unit with batteries or mains power and that
at the critical step 8 you should be ready with your batteries/mains power
lead as appropriate.

1 Either take the batteries out of the OpenTRV controller (batteries) or
remove the power connector (mains)

2 Take the batteries out of the Conrad valve. Hold down the round
grey button in the battery compartment of the Conrad valve until it
beeps or for at least 60 seconds

3 Insert batteries into the Conrad valve (pay attention to the battery
orientation). The display shows C1, then a 2 digit number (the
house code), C2 and again the 2 digit house code.

4 The Conrad valve beeps and A1 appears on the display. The pin
will retract all the way inside the unit to help installation and then A2
appears on the display.

5 Install the Conrad valve onto your radiator and tighten up the cap nut

6 Prepare the batteries to plug in to the OpenTRV unit (batteries) or
ready the mains plug with power (mains). You will need them
quickly after the next step.

7 Make a momentary press of the round grey button until a beep is
heard. The valve will close, the motor whirr and A3 appears on the

8 As soon as the valve stops you will see the flashing antenna on the
display. Quickly put the batteries into the OpenTRV unit (batteries)
or plug the mains adapter into the OpenTRV unit (mains).

9 The LED light on the OpenTRV unit will be flashing constantly until
the Conrad valve beeps (this may take 30 seconds). Once the
OpenTRV unit stops flashing and you hear a beep from the Conrad
valve, they are connected. At this point you can put the battery
cover back on the Conrad valve and start using OpenTRV.

10 If this has not worked, you may see an error code on the Conrad
valve or the OpenTRV unit will not stop flashing. Try the whole
sequence again. If it still fails, contact the OpenTRV team (see the
CONTACT US section later)


It's probably worth mentioning that in my rush to "quickly" repower the
openTRV controller, I mistakenly attached the FTDI connector the wrong way
round. A minute or two of being powered thus doesn't seem to have damaged
the controller ...

This is what I got when I powered the controller a couple of seconds after
seeing the flashing antenna on the TRV:

OpenTRV booting: board V0.2 REV2; code 2014/Mar/23 18:16:08
DEBUG mode with serial logging
Reset count: 39
Free RAM: 1433
posPOST: 1: about to test RFM23
posPOST: 2: RFM23 OK
Vcc: 3315mV
Int temp: 29C / 459
posPOST: 3: internal sensors OK, next light/temp/other
Gathering initial inputs and computing target/demand...
light: 737
temp: 430
temp pot: 1006
posPOST: 4: light/temp OK
posPOST: 5: slow RTC clock OK
? at CLI prompt for help
=F0%@26CE;T11 8 W255 0 F255 0 W255 0 F255 0;S10 10 21 cffO;HC93 74 s
668:22:0 FHT8V SYNC...
=F0%@26CE;T11 8 W255 0 F255 0 W255 0 F255 0;S10 10 21 cffO;HC93 74 s
=F0%@25C1;T11 8 W255 0 F255 0 W255 0 F255 0;S10 10 21 cffO;HC93 74 s

<snip blank lines>

670:26:73 FHT8V SYNC FINAL
672:22:73 FHT8V TX
=F0%@24C4;T11 12 W255 0 F255 0 W255 0 F255 0;S10 10 21 cffO;HC93 74

674:18:73 FHT8V TX
676:14:73 FHT8V TX
=F0%@24C0;T11 16 W255 0 F255 0 W255 0 F255 0;S10 10 21 cffO;HC93 74

678:10:73 FHT8V TX
680:6:73 FHT8V TX
=F0%@24C0;T11 20 W255 0 F255 0 W255 0 F255 0;S10 10 21 cffO;HC93 74

682:2:73 FHT8V TX
683:58:73 FHT8V TX


There were I think two beeps. I thought that the TRV had synced at the
first one, but it beeped again when I wasn't looking at it (probably
between the line with the "s" terminator above and the subsequent
"670:26:73 FHT8V SYNC FINAL"?)

Now the TRV is showing a steady antenna symbol at "0%". I believe this is
correct and normal (and indicates that the valve is 0% open, ie not
supplying heat).

Certainly the TRV *was* in pairing mode overnight. My controller has been
connected to my PC constantly for the past 7 weeks, but the PC is rebooted
at least once daily. However, so far as I can tell, the USB ports still
receive power whilst the PC is shutdown (my phone and tablet battery
indicators suggest as such).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.opentrv.org.uk/pipermail/opentrv-interest/attachments/20140519/f1f781e9/attachment-0001.html>

More information about the OpenTRV-interest mailing list